Movado 75 movement running error

Home Forums General Discussion Forum Movado 75 movement running error

  • This topic is empty.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #50135
    johnno
    Participant
    • Topics Started: 19
    • Total Posts: 55

    I recently managed to straighten the sub seconds post of my vintage Movado 75 movement and it’s beating strongly and the seconds hand is keeping beat with the Atomic clock app I have. However, the time is running about a half hour slow within the hour. I am assuming something is going on around the centre and third wheel? Because the seconds hand is keeping time I am thinking it’s not the balance wheel. Any thoughts or ideas on what this new issue might be would be greatly appreciated! Thanks in advance.

    #65039
    drichards
    Participant
    • Topics Started: 3
    • Total Posts: 35

    Hello John
    I agree. It’s possibly something going on under the dial. Would check that canon pinion fit is sufficient and not slipping, dial washer is doing it’s job and not allowing the hour wheel to disengage from minute wheel, things like that. Those would be my first guesses.
    Interested to know what you discover.
    Good luck, Dean

    #65040
    johnno
    Participant
    • Topics Started: 19
    • Total Posts: 55

    Thanks, Dean. I will let you know.

    btw, should the dial washer curve be facing down or up?

    cheers
    John

    #65041
    drichards
    Participant
    • Topics Started: 3
    • Total Posts: 35

    Hello John,
    The washer position in your picture is correct.

    Dean

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.
johnnoMovado 75 movement running error